Help Center

Creating a Process model using BusinessOptix Author

Creating a new process model

Process modelling is used to:

  • Show the relationship between activities within a process
  • Show interfaces with other processes
  • Help to clarify roles and responsibilities:
    • A process map focuses on roles and responsibilities and may be quite independent of a wider organisation structure
  • Provide a documented and agreed way of how to get things done
  • Help to identify areas of the process that can be improved
  • Facilitate implementation planning and management of change

The benefits of using process mapping diagrams include:

  • Clearly identify who is carrying out each stage of a process, and who else is involved in the previous or following steps, saving time and reducing frustration for all.
  • Visual mapping at a detailed level provides a clearer specification of the process than a written description of the process
  • A searchable online repository of process maps saves time and reduces frustration for service users who can readily establish where responsibility for any stage of a process lies.
  • Visual representation of processes brings benefits for staff induction and training.

There are a number of model types that a user can create in BusinessOptix - 'Process' is the one needed for creating new process models.

 

Table of Contents

1. Start
2. Model Display
3. Components
4. Edit Components
5. Required properties and Verify
6. Saving models
7. Transformation
8. Outputs
9. Additional Support

 


1. Start

To begin, log into your BusinessOptix library and click to access the Models menu. 

mceclip0.png

 

Click the New Model navigation tile then click Process from the selection of model stencils on the following page.  New models can also be accessed from the Author menu.  

Provide the Name of the model, a description of the model and select the author and owner of the model.  Click to create the model.

(Back to table of contents)

 

2. Model Design Display

The screen displays three main areas:

  • Model explorer tabs (left)
  • Model design area (middle)
  • Properties Inspector tabs (right)  

mceclip1.png

 (Back to table of contents)

 

3. Components

Components (BPMN symbols) can be added to the diagram from Components menu. The selected element will be added into the table of contents at the left hand side and displayed in diagram view.

mceclip2.png

Each time a component is added it will automatically link to the component currently selected or highlighted in the table of contents area (in the Model Explorer in the left side panel).

Component properties can be edited e.g. giving the component a name which will label the symbol in the model. Further information can be added in the Activity area of the Properties Inspector on the right of the screen. 

Diagram View

mceclip3.png

Text View

Models can be created and viewed in both Diagram view (default) or in Text view (Click Show Text in the View menu)  

mceclip4.png

 

3.1 Add a Lane

A lane represents a role accountable for and the location of a part of the process.  More than one lane may represent a role or location to make the diagram easier to read. Lanes can be horizontal or vertical depending upon modelling preference for creating a flow. Activities must be mapped within a lane.  

  1. From the Components tab, select the Lane button
  2. Click where you would like the lane to appear in your diagram
  3. From the Properties Inspector:
    • Type in the Name of the lane (such as job role or department)
    • Select who is accountable for the name of the lane (RACI)
      • To do this, select the ‘+’ at the right hand side of Accountable, expand the Role option and tick to relevant accountable option. Then click OK.

mceclip5.png

 

3.2 Add a Start Event

A start event represents an interaction that begins or starts a process.  

  1. From the Components tab, select the Event button
  2. Click where you would like the Event to appear in your diagram
  3. From the Properties Inspector:
    • Change the Type of the Event to Start
    • Name the event e.g. Start

mceclip6.png

 

3.3 Add an Activity

An activity component represents a task or work being performed.  A process activity can be completed by humans or systems and be responsible to more than one party or individual.

  1. From the Components tab, select the Activity button
  2. Click where you would like the Activity to appear in your diagram
  3. In the Properties Inspector type in or select the required information.
  4. For example:
  • Name (this will label the activity in the diagram)
  • Lane (which lane to add the activity to)
  • Type of task
  • After – click the + to select which activity it should follow
  • References - click the + to add reference information to the activity step
  • Description – if you need to elaborate on the activity, type in the description field. This has an unlimited text length and will appear in the pop up in the html output when the element is clicked on or the relevant paragraph in the PDF outputs
  1. From the Properties Inspector Details tray, apply RACI:
  • Select the Location for the Responsible Person(s) e.g. Finance or physical location  – to do this click the ‘+’ next to locations, expand the role option and tick the appropriate location(s). If the item is not on the list, contact the BusinessOptix administrators to update the list. Refer to the Master Data section of this guidance.
  • Select who is Responsible for the activity e.g. Administrator
  • Select a system that performs the task if necessary, e.g. Agresso
  • Add other options as required in the Details tray

Note: RACI’s accountable is labelled via the Properties Inspector on each lane.

mceclip7.png

 

 


Hints and Tips for Creating Clear Activity Name / Labels

  1. Use verb / noun syntax for activities. “DO something TO something”. Avoid intransitive verbs (verbs with no noun - e.g. “work hard”) and function labels (nouns with no verb – e.g. “marketing”)
  2. Keep the words as simple and straightforward as possible – “Allocate Tasks to People” is easier to understand than “Deploy Resources to Fulfill Plan”
  3. Try to reflect the purpose of the activities in the words you choose – e.g. if a document is being put out for review “Obtain Feedback” says more than “Issue Draft”.
  4. Make verbs as active as possible and nouns as tangible as possible  – “Buy tickets” is better than “Arrange travel”
  5. Avoid putting multiple activities into a single box. Using the word “and” is a clue that you may be doing this.
  6. Make nouns as specific as possible for the level of the model. Generally, nouns will be more specific the lower the level you’re working at.  E.g. - at high level an activity might be stated as “Assess Damage”, but at lower level this might break down to “Visit Premises”; “Complete Inventory Form”; “Produce Damage Assessment Report”…
  7. Avoid documenting activities that are implied by the model - e.g. if a line comes into Role B’s swim lane from an activity in Role A’s saying “Produce Preliminary Report”, there’s no need to have an activity for Role B saying “Receive Preliminary Report”.
  8. Avoid ambiguity – e.g. “Update Management” could mean “tell the managers what’s going on” or “update the fields in the system on the “Management” form” or could be the name of another process about managing software updates.

 

3.4 Use a Gateway

A gateway represents a decision point in a process where alternative and/or parallel paths begin or end.  Gateways require at least two outputs when used in a flow. 

  1. From the Component tab, select the Gateway button
  2. Click where you would like the Gateway to appear in your diagram
  3. In the Properties Inspector type in or select the required information. For example:
  • Name (this will label the gateway in the diagram).
  • Lane (which lane to add the activity to)
  • Type (if required)
  • After (what component it comes after)
  • References (to add reference information to the gateway)
  • Description – if you need to elaborate on the gateway, type in the description field. This has an unlimited text length.

mceclip8.png

Under Details you can position the label on the gateway - Show label

 

3.5 Add Links to Existing Components

Links represent relationships.

  1. Select the component the link will appear from (source)
  2. From the Component tab, click the Link button
  3. Click the component it will go to  (target / destination) – see the arrow link appear

mceclip9.png

3.5.1 Move Links

Links may need manipulating to display as required. To do this:

  1. Select the link, then  choose which handle to drag:
  • The square handle will resize the link
  • The diamond handle will move the link location – sometimes the diamond shaped handle is very close to the square handle.

Tip: If you are struggling to move the link – hover your mouse over the handle until the cursor changes to the hand symbol, and then drag it to the location required.

 

3.6 Add Banners / Labels / Notes

  1. From the Components tab, click the Label button
  2. Click where the Label should appear in the diagram
  3. From the Properties Inspector (in the Label tray), type in the text to be displayed
  4. If you wish to draw a dotted associated line to an element in the diagram:
  • Select the Label in your diagram
  • From the Component tab, click Link button
  • Click the component it will go to – see the link appear

mceclip10.png

Under details you can change the colour of the label / banner also the font colour and size.

 

3.6.1 Using an Information Store

An information store represents a deliverable to, within or from a process.

  1. From the Component tab, click the Information button
  2. Click where the Information Icon should appear in the diagram
  3. In the Properties Inspector type in or select the required information. For example:
  • Name (add a label for the Information component)
  • State (draft / approved)
  • Lane  (which lane to add the activity to)
  • References (to add reference material to the information)
  • Description - if you need to elaborate on the information name, type in the description field. This has an unlimited text length.

mceclip11.png

 

3.7 Add Groups

Groups are used to define or 'group' related parts of a process.

  1. From the Component tab, click the Group button
  2. Click in the diagram where you wish the group to appear
  3. Resize and move the group as required
  4. From the Properties Inspector, type in a name and description (if required) for the group

mceclip12.png

 

3.8 Add Text Sections

  1. From the Component tab, click the Text button
  2. Click in the diagram – see a section appear below the model name in the Table of Contents
  3. In the Properties Inspector type in or select the required information. For example:
  • Give the Section a Heading
  • Choose the Position of the section (Before or after the diagram and its related information)
  • Add Links if needed
  • Type in the content of the section

mceclip13.png

Tip: Sections can be nested to recreate document sections and sub paragraphs.

 

3.9 Add an End Event

An end event represents an interaction that completes or ends a process. When you are ready to finish your flow diagram, add an end event. 

  1. From the Component tab, select the Event button
  2. Click where you would like the Event to appear
  3. From the Properties Inspector, change the Type of the Event to End

mceclip14.png


(Back to table of contents)

 

4. Edit Components

4.1 Delete a Component

Right click on the component in the Table of Contents or directly on the component in the diagram, and then select the delete option.

 

4.2 Move a Component

Select the required component then either:

  • From the Properties Inspector, change what component it is placed after, or
  • Which lane it should be in, or
  • Drag the component where it is required.
  • Left / Right / Up Down Arrow keys - use to move components / snap to grid

Tip: To move the entire diagram: click in the diagram, press CTRL and A key from the keyboard - see all components selected and then drag components to new area on the diagram.

 

4.3 Aligning Components

To improve the presentation of the diagram, you can align selected components to the left, right, top or bottom edges. Selected components can also be centered vertically or horizontally if preferred, in relation to each other.

4.3.1 Align Components to a Selected Component

mceclip15.png

  1. Select the component you wish to align other components to
  2. Hold down the CTRL key on the keyboard and the select the other components
  3. Right mouse click on one of the selected objects and select the Align option required

4.3.2 Re-link Components

The RE-LINK option from the right click helps restructure the diagram to improve the presentation based on redrawing the horizontal and vertical links between components.

  1.  Click the link between components (or select multiple links by holding down Ctrl while selecting multiple links.
  2. Click the Relink button under the Actions tab in the menu.

mceclip16.png

(Back to table of contents)

 

5. Required properties and Verify models

5.1 Required Properties

BusinessOptix verification reviews core attributes within process components to aid creating industry standard BPMN 2.0 process models.  BusinessOptix has identified certain properties as required because it's either good practice to have the information (for example a description of a process) or are required for some model outputs to work properly (for example a data source is required on a dashboard chart)  While authoring a model we've made it easier to understand which properties are required and whether they have been entered. 

mceclip2.png

Required properties are indicated with an asterisk following the Property Name (*).  When the property has not been entered the property is highlighted with a red background. The absence of a required property does not stop the author from saving a model.

5.2 BusinessOptix Verify

BusinessOptix uses BPMN 2.0 industry standards for verification of process models.  This works by simulating running the process a number (by default, a thousand) of times, and tracing through each step of the process.

Whenever a conditional link is reached, its probability (set on the Metrics page) is used to determine whether that path will be taken.

  1. After saving the model, click the Verify button under the Actions tab.
  2. Each issue found can be sourced by clicking the hyperlinked name at the beginning of the issue bullet

mceclip17.png

 

 

6. Saving a Model to a Library in Author

Note:

If you are saving to the My Work Folder on BusinessOptix versioning is not available.

If saving in the Shared library area; versioning is fully supported.

  1. Click the File tab from the Author menu.
  2. Select the Save option
  3. If the model is saved to your My Work folder and you wish to move it to Shared, select Move/Copy from the File tab and select the folder you wish to move/copy to
  4. Click the Move button
  5. If you wish to copy the model or create a new model using the current model as template, select Move/Copy from the File tab and select the folder you with to copy the model to
  6. Type in a new name for the copied model
  7. Click the Copy button

mceclip18.png

(Back to table of contents)


7. Transformation

7.1 RACI - Responsible, Accountable, Consulted, Informed

RACI for the whole process or each activity is defined using the 'Details' section of the right hand screen - all activities need 'Responsible' defined.

  • Responsible (using the Details section)
  • Accountable (form the swim-lane)
  • Consulted (using the Details section)
  • Informed (using Details section)

mceclip19.png

 

7.2 Apply Metrics to an Activity

  1. From the process model, click on the activity you wish to apply some statistics to
  2. From the Properties Inspector, select the Metrics tray
  3. Enter the required information
  4. Repeat for any other activities, as required, in the process model

mceclip20.png

7.3 Apply Transformation to an Activity

  1. From the process model, click on the activity to apply a transformation to
  2. From the Properties Inspector, select the Transformation tray
  3. Select the Action required e.g. Modify, Add, Drop or Keep activity
  4. Type in the estimated fixed cost saving of the change
  5. Type in the estimated annual cost of the change
  6. Repeat for any other activities, as required, in the process model

mceclip21.png

7.4 Change Model View e.g. see the 'To Be' view

  1. From the Table of Contents, click on the Process name (it’s toward the top – all the swim lanes and steps branch out from it)
  2. From the menu tab selections, select the View tab
  3. Choose the View selection for viewing transformation differences  (e.g. changes, current state (as is) or future state (to be)

mceclip22.png

 

7.5 Comparing 'As Is' and 'To Be' Models

BusinessOptix enables the author to create different ‘views’ of a process model. This enables a user to compare an ‘as is’ process model with a ‘to be’ process model. Comparing current and future models makes it possible to see the financial implications of a potential change in the process e.g. if an activity is dropped (not needed) or modified.

Activities within a model can have metrics applied. ‘Metrics’ are statistics relating to the activity e.g. Time the activity takes, unit cost of the activity, number of FTEs needed to perform the activity, cost of FTE.

To create a future view (e.g. a ‘to be’ model) in an existing process model, a user can apply transformation changes to one or more activities. This also enables the user to input the estimated fixed costs and expected annual saving based on the change.

BusinessOptix allows the user to look at the current state and then change the view to a future state to show how the model would look if the changes took place.

A report can be created which applies statistical analysis to the ‘as is’ and ‘to be’ views of the model to highlight the financial costs and benefits of changing the process.

The process maps that are created can be saved in various formats via the Output tab. These outputs are saved to your computer with the option of also saving them to your library.

These outputs often contain more information than is displayed on the diagram. For example some output styles include detailed descriptions whilst others include the RACI information.

Available reports include:

  • HTML: Display the model in web-based version in your browser.
  • PDF: Save a copy of the model in PDF format
  • Data: Save a copy of the model in table format
  • Visio: Save a copy of the model diagram in Visio format
  • Image: Save a copy of the currently viewed diagram in Author as a jpg or png image
  • Delete outputs: Removes the previous outputs to the model

mceclip23.png

 

(Back to table of contents)

9. Additional Support

If you need additional Support - please see your library's System Administrator.  If required library administrators will liaise with BusinessOptix on your behalf.

 

 

 

Was this article helpful?

12 out of 15 found this helpful

Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.